Elevated client-side streaming errors
Incident Report for LaunchDarkly
Resolved
This incident is resolved, and all current communications will take place here: https://status.launchdarkly.com/incidents/c9dwr6sv8l13
Posted Oct 18, 2022 - 21:44 PDT
Update
All errors are resolved, but we’re continuing to monitor this incident through tomorrow morning out of an abundance of caution.
Posted Oct 17, 2022 - 19:47 PDT
Monitoring
Client stream connections are once again operational, though we are continuing to monitor for further errors.
Posted Oct 17, 2022 - 18:59 PDT
Update
Error rate is dropping. As before, most client-side connections will eventually succeed despite errors. We are continuing to work on remediation.
Posted Oct 17, 2022 - 17:45 PDT
Update
Error rate is holding steady. As before, most client-side connections will eventually succeed despite errors. We are continuing to work on remediation.
Posted Oct 17, 2022 - 16:44 PDT
Update
Client streaming connection error rate has decreased, but we are still seeing some errors. The team is continuing to work toward a resolution. Note that SDKs will retry upon error, and most connections will eventually succeed.
Posted Oct 17, 2022 - 16:11 PDT
Update
We are continuing to actively investigate this issue and will continue to provide regular updates. Currently, we are still seeing a high rate of timeouts for client-side streaming connections.
Posted Oct 17, 2022 - 15:34 PDT
Identified
We have identified the issue, and the team is attempting mitigation strategies.
Posted Oct 17, 2022 - 14:44 PDT
Update
We are experiencing errors initializing client-side SDK streams. We will post updates as we continue to investigate.
Posted Oct 17, 2022 - 13:41 PDT
Update
We are continuing to investigate this issue.
Posted Oct 17, 2022 - 13:30 PDT
Investigating
We are investigating increased error rates on client-side streaming connections.
Posted Oct 17, 2022 - 11:45 PDT
This incident affected: Flag Delivery Network (core functionality) (Client-side streaming API).