Client-side Streaming SDK Degraded Performance
Incident Report for LaunchDarkly
Resolved
This incident has been resolved.
Posted Oct 19, 2022 - 17:23 PDT
Update
We are continuing to monitor for any further issues. Systems remain fully operational at this time.
Posted Oct 19, 2022 - 06:45 PDT
Update
Clients are connecting normally. Systems remain fully operational at this time.
Posted Oct 19, 2022 - 02:26 PDT
Update
We are continuing to monitor additional mitigations. Systems remain fully operational at this time.
Posted Oct 18, 2022 - 23:06 PDT
Monitoring
Client initialization timeouts have resolved and clients are connecting normally. We will continue to monitor the situation.
Posted Oct 18, 2022 - 20:30 PDT
Update
We are continuing to work on a fix, and are still observing timeouts on client-side streaming connections.
Posted Oct 18, 2022 - 19:21 PDT
Identified
We have identified the issue and are working on a fix. Meanwhile, we are still seeing timeouts on client-side streaming connections.
Posted Oct 18, 2022 - 18:37 PDT
Investigating
We are investigating new instances of timeouts on client-side streaming connections.
Posted Oct 18, 2022 - 18:10 PDT
Update
We continue to monitor the system and remain in a stable state.
Posted Oct 18, 2022 - 14:19 PDT
Update
We continue to monitor errors rates and have not seen a reoccurrence of this issue.
Posted Oct 18, 2022 - 11:07 PDT
Update
We continue to monitor errors rates after applying a fix and have not seen a reoccurrence of this issue.
Posted Oct 18, 2022 - 09:17 PDT
Monitoring
We have applied a fix and are monitoring the results.
Posted Oct 18, 2022 - 06:24 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 18, 2022 - 05:53 PDT
Identified
While Asia Pacific has remained stable, we are now experience elevated connection errors in Europe. We are attempting mitigation.
Posted Oct 18, 2022 - 05:53 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2022 - 04:31 PDT
Update
We have eliminated the connection errors and are continuing to monitor the system.
Posted Oct 18, 2022 - 03:32 PDT
Identified
We are experiencing elevated errors initializing client-side SDK streams in the Asia Pacific region. Clients may encounter 5xx errors when they attempt to initiatlize a streaming connection. Clients will retry until they connect. We will post updates as we continue to investigate.
Posted Oct 18, 2022 - 02:46 PDT
This incident affected: Flag Delivery Network (core functionality) (Client-side streaming API).