Rule attribute selector causing flag targeting web interface to crash
Incident Report for LaunchDarkly
Postmortem

On September 30 we introduced a bug in our frontend code that resulted in an error page being displayed when attempting to use the rule attribute selector (the first dropdown when creating or editing a targeting rule). This bug only affected environments where one or more private attributes had been declared within a LaunchDarkly SDK. Once we became aware of the issue we were able to revert the change and restore full functionality.

Our tests did not cover the case of private attributes for this component, which is why the bug was not caught earlier in our development cycle. Going forward, we are implementing both unit tests and integration tests that will exercise this and other frontend code when private attributes are in use.

Posted Oct 06, 2021 - 10:24 PDT

Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 14:30 PDT
Monitoring
A fix has been implemented and we will continue to monitor for any lingering issues.
Posted Sep 30, 2021 - 14:18 PDT
Investigating
Some customers are seeing an error page when attempting to use the attribute selector on the flag targeting page. We have identified the issue and are working on a fix.
Posted Sep 30, 2021 - 14:00 PDT
This incident affected: Feature management (core functionality) (Flag targeting).