Delays for Customers Using the Cloudflare Edge SDK

Incident Report for LaunchDarkly

Resolved

Our partner has confirmed full restoration of their platform. We began observing full recovery starting at 2:07PM PT.
Posted Jun 12, 2025 - 14:52 PDT

Monitoring

Our partner is reporting partial recovery on their platform. We are still observing intermittent delays in the Edge SDK and warehouse-native data export. We'll continue to monitor and update when full platform recovery has been completed by our partner.
Posted Jun 12, 2025 - 13:20 PDT

Update

We have been notified our vendor handling data warehouse export functionality is also impacted. LaunchDarkly customers using warehouse-native data export may experience data delays until the partner issue is mitigated.
Posted Jun 12, 2025 - 12:37 PDT

Update

We are continuing to monitor the status with our partners. Edge SDK customers continue to experience intermittent delays.
Posted Jun 12, 2025 - 12:17 PDT

Identified

LaunchDarkly customers leveraging the Cloudflare Edge SDK may experience intermittent delays in processing flag changes. This is due to broad platform wide outages at Cloudflare. We're continuing to investigate the status with this partner. All other edge SDK's should be functioning normally. We'll post an update when available from Cloudflare.
Posted Jun 12, 2025 - 11:47 PDT
This incident affected: Feature management (non-core functionality) (Data Export) and Flag Delivery Network (core functionality) (Edge API).