Elevated error rates in usage and flag endpoints

Incident Report for LaunchDarkly

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 08:10 PDT

Monitoring

We have addressed the backend performance issues and are no longer observing elevated error rates on the impacted endpoints.
Posted Jul 22, 2025 - 07:17 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 22, 2025 - 06:45 PDT

Identified

We have identified an issue causing elevated error rates on a small subset of requests on the LaunchDarkly platform. Some users may experience 5xx errors when calling the following endpoints.
- Usage data endpoints
- GET flag(s) endpoint

We are currently working to mitigate the underlying root cause.
Posted Jul 22, 2025 - 06:44 PDT
This incident affected: Feature management (core functionality) (Flag targeting) and Feature management (non-core functionality) (Flag usage metrics).