Browser SDKs are unable to connect to LaunchDarkly

Incident Report for LaunchDarkly

Resolved

Between 1:08 PM UTC (6:08 AM PT) and 4:25 PM UTC (9:25 AM PT) on Tuesday, May 27, 2025, customers may have experienced issues with their browser SDKs connecting to the Flag Delivery Network's polling services. This time window represents the outer bounds of potential impact; each customer's actual impact may vary depending on the cache expiry of their environment data.

Customers who have implemented their own caching mechanisms outside of LaunchDarkly's SDKs may have had additional recovery time.

We resolved the issue and impacted services have returned to normal operation.
Posted May 27, 2025 - 09:44 PDT

Update

Polling connections are continuing to fully recover for impacted browser SDKs.
Posted May 27, 2025 - 09:40 PDT

Monitoring

A fix has been implemented and Browser SDK connections continue to recover while we clear cached errors from the polling service.
Posted May 27, 2025 - 07:38 PDT

Update

Only browser SDKs are affected by this incident. The team has determined that non-browser SDKs (e.g. mobile and desktop SDKs) are unaffected.

SDK connections are starting to come back online and recover.
Posted May 27, 2025 - 07:29 PDT

Identified

Client-side and mobile SDKs are unable to connect to the Flag Delivery Network’s polling capability. Impacted SDKs will continue to serve last known-good flag values.

Server-side SDK connectivity is unaffected, as is client-side and mobile streaming connectivity. The ability to manage flags is also unaffected.
Posted May 27, 2025 - 07:11 PDT

Update

We are continuing to investigate this issue.
Posted May 27, 2025 - 06:56 PDT

Investigating

Client SDK users are experiencing CORS errors
Posted May 27, 2025 - 06:54 PDT
This incident affected: Flag Delivery Network (core functionality) (Polling API) and SDKs.