Issue saving targeting rules with semantic versioning operators
Incident Report for LaunchDarkly
Resolved
This issue turned out to be a false alarm; flag targeting rules are being saved correctly.
Posted Jul 26, 2022 - 09:12 PDT
Investigating
We are currently investigating an issue with saving targeting rules that include semantic versioning operators. Specifically, the `semver >=` operator is being saved as `semver `. Rules saved with incorrect values will use those incorrect values in live flag evaluation. We are reviewing whether this issue affects other operators.
Posted Jul 26, 2022 - 08:42 PDT
This incident affected: Feature management (core functionality) (Flag targeting).