Missing last seen data for members
Incident Report for LaunchDarkly
Resolved
We are not planning additional work on this issue over the US Thanksgiving holiday weekend. We will update the status of any additional remediations by EOD Pacific Time on Monday, November 29th.
Posted Nov 24, 2021 - 19:15 PST
Identified
We have identified an issue with missing "lastSeen" times for members last visiting the site and access tokens last used prior to November 12, 2021. We have restored "lastSeen" timestamps for members who accessed via the web interface prior to November 12. "lastSeen" timestamps that should be dated before November 12 are still missing from API, leading to some members being shown as never having visited the site and some access tokens shown as never having been used. "lastSeen" timestamps for members who have used the site via the web or an access token since November 12 are accurate. "lastSeen" timestamps for access tokens that have been used since November 12 are also accurate.

We are continuing to work to restore "lastSeen" timestamps for members and access tokens that would be based purely on access token accesses prior to November 12.
Posted Nov 24, 2021 - 18:38 PST
Investigating
We are investigating an issue around missing data for members' last activity. Currently this field is absent for all members and API tokens which have not been used since Friday, Nov 12 at 4:24PM PST.
Posted Nov 24, 2021 - 14:30 PST
This incident affected: API and Web interface.