Investigating - Known Impact

Incident Report for LaunchDarkly

Monitoring

The issue with Observability Traces has been identified and a fix has been implemented. We have recovered most trace data that was missing from July 30th 5:16pm to July 31st 10:59am PT. We will resolve the incident once we fully complete data recovery (expected to complete by 5pm PT).
Posted Jul 31, 2026 - 14:58 PDT

Identified

Customers are experiencing missing Observability Traces ingested from July 30th 5:16pm until July 31st 10:59am PT. Observability Logs / Metrics are unaffected.

We have identified the issue and are continuing our work to recover the missing Traces data.
Posted Jul 31, 2026 - 10:59 PDT

Investigating

All customers are experiencing missing Observability Traces starting July 30th at 5:16pm PT. We are investigating and will provide updates as they become available. Trace data is not lost and we are working to recover it.
Posted Jul 31, 2026 - 10:44 PDT
This incident affects: Observability (core functionality) (OpenTelemetry (Logs, Traces, Metrics)).