Issue with viewing usage charts and making changes to self-serve billing
Incident Report for LaunchDarkly
Resolved
The fix has been deployed and we have resolved this issue.
Posted Oct 18, 2023 - 13:42 PDT
Identified
We have identified the cause of the issue and are working on a fix.
Posted Oct 18, 2023 - 11:57 PDT
Investigating
We are currently investigating an issue viewing usage charts and updating self-serve billing in the product
Posted Oct 18, 2023 - 11:36 PDT
This incident affected: Account management.