Delayed processing of Session Replay and Error data

Incident Report for LaunchDarkly

Resolved

All queued events have been processed and data ingestion is operating normally. No data was lost during this incident.
Posted May 15, 2026 - 18:13 PDT

Identified

We have identified the issue and a fix is in progress. The backlog is actively decreasing. No data has been lost — all queued events will be processed.
Posted May 15, 2026 - 17:14 PDT

Investigating

We are currently experiencing a delay in processing Session Replay and Error event data. Incoming data is being queued and will be processed — no data has been lost. Customers may observe a temporary lag in session and error data appearing in the LaunchDarkly UI.
Posted May 15, 2026 - 17:03 PDT
This incident affected: Observability (core functionality) (Observability Data Ingest (Sessions, Errors)).