The delayed processing of Session Replay and Error event data has been resolved. All queued events have been processed and data ingestion is operating normally. No data was lost during this incident. Thank you for your patience.
Posted Apr 06, 2026 - 12:02 PDT
Monitoring
The delayed processing of Session Replay and Error event data has been resolved. All queued events have been processed and data ingestion is operating normally. No data was lost during this incident. Thank you for your patience.
Posted Apr 06, 2026 - 11:40 PDT
Update
We have identified the cause of the delayed Session Replay and Error event processing and a fix is in progress. The backlog is actively decreasing. No data has been lost — all queued events will be processed.
Posted Apr 06, 2026 - 11:15 PDT
Identified
We are currently experiencing a delay in processing Session Replay and Error event data. Incoming data is being queued and will be processed — no data has been lost. Customers may observe a temporary lag in session and error data appearing in the LaunchDarkly UI.
We have identified the root cause as elevated database utilization and are actively working to resolve the backlog. We will provide updates as processing returns to normal.
Posted Apr 06, 2026 - 10:58 PDT
This incident affected: Observability (core functionality) (Observability Data Ingest (Sessions, Errors)).