Event processing delays

Incident Report for LaunchDarkly

Resolved

The issue with Event processing has been resolved. Impacted services have returned to normal operation.

Flag Delivery was not impacted.

There was no data loss experienced.
Posted Mar 10, 2026 - 21:07 PDT

Update

We are continuing to monitor for any further issues.
Posted Mar 10, 2026 - 16:42 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 16:38 PDT

Investigating

Event processing is currently delayed for and will show stale data for several product areas, including:
- Autogenerated metric creation
- Data Export
- Experimentation

No data has been lost.
Posted Mar 10, 2026 - 15:59 PDT
This incident affected: Experimentation (core functionality) (Experiment results processing, Warehouse native experimentation).