Email delivery is delayed
Incident Report for LaunchDarkly
Resolved
Emails are once again being delivered. We believe this was caused by a large backlog in our mail delivery service, and is now resolved.
Posted Aug 10, 2022 - 14:44 PDT
Monitoring
We believe this is resolved and emails are being delivered again.
Posted Aug 10, 2022 - 14:25 PDT
Investigating
We are currently investigating an issue where password reset and member invite emails are being delayed by up to 2 hours. Right now, we don't believe email verification and approval request notification emails are affected.
Posted Aug 10, 2022 - 14:00 PDT
This incident affected: Feature management (non-core functionality) (Emails and notifications) and Account management.