Account Usage Charts for Server Side SDKs Degraded

Incident Report for LaunchDarkly

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 16:43 PDT

Monitoring

We have implemented a fix for the Account Settings Usage Charts for server side SDKs under-reporting the connection counts and we are monitoring the results. Customers should start seeing new connection counts show up in the charts. We are unable to backfill the missing under-reported data from July 26 to Aug 5.
Posted Aug 06, 2025 - 15:30 PDT

Identified

The issue with account usage charts for server side SDKs connection metrics has been identified and the fix is being implemented.
Posted Aug 06, 2025 - 12:02 PDT

Investigating

We are investigating the issue with the Account Settings Usage Charts for server side SDKs under-reporting the connection counts for most customers since July 26.
Posted Aug 06, 2025 - 10:46 PDT
This incident affected: Account management.