Event Processing Delays
Incident Report for LaunchDarkly
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 13:18 PST
Update
We have a fix implemented and are continuing to monitor results.
Posted Mar 10, 2023 - 12:39 PST
Update
We are seeing increasing delay on event processing and error rates. We are continuing to work on mitigations for this issue.
Posted Mar 10, 2023 - 12:27 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2023 - 11:45 PST
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2023 - 09:25 PST
Identified
We have identified the issue and started implementing a solution. Our events pipeline is recovering, but event processing is still delayed.

EDIT: Customers may have seen 500 errors when performing actions with the APIs for Flag Statuses, Flag Insights, Context Dashboard, Auto Completion during the Investigation time. Those issues are now resolved as we have identified and are implementing a fix.
Posted Mar 10, 2023 - 08:27 PST
Update
We are continuing to investigate this issue.
Posted Mar 10, 2023 - 06:57 PST
Investigating
Event processing is currently delayed for and will be showing stale data for:
Flag Statuses
Flag Insights
Context Dashboard
Auto Completion

No data has been lost and the system should be caught up shortly.
Posted Mar 10, 2023 - 05:05 PST
This incident affected: Feature management (non-core functionality) (Data Export, Flag usage metrics) and Experimentation (core functionality) (Experiment results processing).