Email delivery failure affecting sign-up verification and notification emails

Incident Report for LaunchDarkly

Resolved

Email delivery has been restored as of 2:32 PM UTC. Sign-up verification, password reset, teammate invitation, and notification emails are sending normally again.

We are re-sending sign-up verification and password reset emails that failed to deliver during the incident window (August 22, 11:48 PM CDT through today). If you attempted to sign up or reset a password during that period and haven't received an email within the next few hours, please retry the action or contact support.

We are continuing to monitor email delivery closely and will post a final update once we've confirmed sustained recovery.
Posted Aug 24, 2026 - 06:36 PDT

Identified

Emails sent by LaunchDarkly — including sign-up verification, password reset, teammate invitation, and workflow notification emails — are currently failing to deliver due to an authentication issue with an upstream email delivery provider. We have identified the cause and are working to restore delivery.

Feature flag delivery, SDKs, and the LaunchDarkly application itself are not affected.

If you are trying to complete sign-up or reset a password, those emails will not arrive until this is resolved. Once delivery is restored, we will re-send affected verification and password reset emails.

Next update within 2 hours.
Posted Aug 24, 2026 - 05:20 PDT