Flag Evaluation Latency

Incident Report for LaunchDarkly

Resolved

We have addressed the source of the latency on flag evaluations and all affected endpoints.
Posted Aug 21, 2025 - 16:05 PDT

Update

We are continuing to investigate the intermittent latency and have engaged our backend partner to facilitate the investigation.
Posted Aug 21, 2025 - 12:59 PDT

Investigating

We are aware of some customers experiencing brief periods of latency in flag evaluations and flag list endpoints. We are continuing to investigate and will provide an update shortly.
Posted Aug 21, 2025 - 11:51 PDT
This incident affected: Feature management (non-core functionality) (Flag usage metrics).