LaunchDarkly investigating stale flag data on new client connections
Incident Report for LaunchDarkly
Resolved
Clients connected between 1758 and 1816 PST have been reconnected and are now serving their correct flag states. This incident is resolved.
Posted Oct 03, 2019 - 19:32 PDT
Monitoring
LaunchDarkly engineers are correcting a problem that affects customers that made flag changes between 1758 and 1816 PST.

Members who made flag changes (e.g. targeting rule updates, toggling flags on and off, changing configurations on flags) between 1758 and 1816 PST may be receiving the state recorded before 1758 on mobile sdks that connect via stream. The server SDKs, client SDKs (e.g. connection via the clientkey), and those who poll are not affected.

Our engineers have isolated the problem and all new connections from mobile SDKs should now be getting correct values for changes 1816. We are working on a solution that resolves the situation for clients connected between 1758 and 1816 PST.
Posted Oct 03, 2019 - 18:49 PDT
This incident affected: Flag Delivery Network (core functionality) (Server-side streaming API).