Mobile and Server SDKs are intermittently down

Incident Report for LaunchDarkly

Update

Customers continue to successfully reestablish connections to our streaming services.

We recommend reviewing your application logs for the incident window. Affected SDKs emit messages—varying by language—that contain any of the following: "giving up permanently," "Invalid SDK key," "unauthorized," "not authorized," or "401." Any service that logged these messages may be unable to receive flag updates or send event data until it is restarted.

Here are the recommended actions for each affected application:
- If you use server-side SDKs, please restart the application to re-establish its connection to LaunchDarkly.
- If you use the Relay Proxy, please restart the Relay Proxy to re-establish connections. It should not be necessary to restart the applications behind it.
- Client-side SDKs will reconnect automatically as they restart.
- If this does not resolve the issue for an affected application (e.g. you still see the log messages from above), please log a support ticket and we will follow up with you directly to assist with remediation.
Posted Jul 10, 2026 - 16:32 PDT

Monitoring

Our Flag Delivery services have recovered and we're observing an increase in customer traffic successfully reestablish connections to our streaming services. Customers who continue to encounter 401 connection errors in their SDKs or Relay Proxy instances are advised to restart their applications and/or Relay Proxy instances.
Posted Jul 10, 2026 - 13:18 PDT

Investigating

We are investigating continued impact to customers' mobile and server SDK caused by the previous incident (https://status.launchdarkly.com/incidents/chywwz01ptb0). If customers are receiving SDK or Relay Proxy 401s please re-establish connections.
Posted Jul 10, 2026 - 09:00 PDT
This incident affects: SDKs.