Increased API latency and error rate

Incident Report for LaunchDarkly

Resolved

This incident has been resolved.
Posted May 24, 2023 - 10:29 PDT

Monitoring

System health has remained healthy since our previous update at 8:07 PDT. We're continuing to monitor the system health at this time.
Posted May 24, 2023 - 08:56 PDT

Identified

We have identified the issue and made a change that have restored access to the web app and returned the API to normal. We are not yet confident that full problem has been eliminated, however, and we are continuing to investigate.
Posted May 24, 2023 - 08:07 PDT

Investigating

We are currently investigating increased latency and timeout-related error rates in our REST API.

This will result in slow responses or time-outs when logging in to the web app to create or update flags. The Flag Delivery Network and flag evaluations are unaffected.
Posted May 24, 2023 - 07:51 PDT
This incident affected: Feature management (core functionality) (Flag targeting).