Elevated error rates on event data ingestion endpoints

Incident Report for LaunchDarkly

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 09:06 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 08:13 PDT

Investigating

We are investigating elevated error rates on our event data ingestion endpoints affecting production customers, between approximately 7:00 AM PDT and 7:15 AM PDT. During this window, a portion of feature flag, experimentation, and AI/agent event data may have been rejected or delayed.

Flag delivery and evaluation are not affected. SDKs continue to serve flags normally. Observability ingest is not affected.
Posted Jul 03, 2026 - 07:29 PDT
This incident affected: Global (core functionality) (Metrics), Feature management (non-core functionality) (Flag usage metrics), Experimentation (core functionality) (Experiment results processing), Guarded Rollouts (core functionality) (Rollout results analysis), and Agents (core functionality) (AI insights).