Elevated TLS negotiation error rate for SDKs in streaming mode

Incident Report for LaunchDarkly

Resolved

The issue with TLS handshake errors from SDKs to our streaming service has been resolved.
Posted Aug 11, 2025 - 12:51 PDT

Monitoring

We are no longer experiencing elevated error rates. We are continuing to monitor the performance of our streaming service.
Posted Aug 11, 2025 - 12:29 PDT

Identified

We have identified the issue with the TLS handshake errors from SDKs for small number of customers. We have reverted the change and expect elevated error rates intermittently while the change is rolled out.
Posted Aug 11, 2025 - 12:00 PDT

Investigating

We are investigating reports of TLS handshake errors from SDKs to our streaming service for small number of customers. Polling SDKs are not affected.
Posted Aug 11, 2025 - 11:25 PDT