Elevated Error Rates in Event Ingestion

Incident Report for LaunchDarkly

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 13:17 PDT

Monitoring

All event ingestion errors have been resolved and downstream services processing event data have been restored to normal operations.
Posted Jul 21, 2025 - 12:56 PDT

Identified

Engineers have scaled the event service to resolve the majority of error rates. Users should experience a reduction in the errors on events.launchdarkly.com. Some downstream services in the event data warehouse are still not being updated. We will update to monitoring once we observe the remaining services recover.
Posted Jul 21, 2025 - 12:26 PDT

Update

We are continuing to investigate this issue and implementing steps to address the error rates. Users may experience errors when calling the events.launchdarkly.com endpoint.
Posted Jul 21, 2025 - 12:19 PDT

Investigating

We are currently observing elevated errors in event data ingestion related to experiments, data export, and other areas of the LaunchDarkly platform. Users may experience stale data when using these features.
Posted Jul 21, 2025 - 12:14 PDT
This incident affected: Feature management (non-core functionality) (Data Export) and Experimentation (core functionality) (Experiment results processing).