Identified
Incident Report for LaunchDarkly
Resolved
The issue with self-serve billing changes has been resolved. Impacted services have returned to normal operation
Posted Oct 15, 2024 - 08:31 PDT
Identified
Customers are unable to sign-up or make changes to self-serve billing plans. We have identified the issue and are continuing our work to resolve it.
Posted Oct 15, 2024 - 06:49 PDT
This incident affected: Account management.