Outbound mail delivery issues
Incident Report for LaunchDarkly
Resolved
Mailgun reports that their performance issues have been resolved, though they're continuing to monitor.
Posted 7 months ago. Jan 12, 2017 - 14:19 PST
Update
Mailgun is reporting improved performance. We're continuing to monitor on our end.
Posted 7 months ago. Jan 12, 2017 - 11:50 PST
Monitoring
Our mail provider (Mailgun) is reporting degraded performance. This is causing delays in e-mail delivery, as well as issues clicking links in our transactional e-mails. We're monitoring the issue.
Posted 7 months ago. Jan 12, 2017 - 11:40 PST